Author Topic: Sony STR-242S issue when equaliser attached  (Read 386 times)

Offline arendedwinter

  • FNG !!!
  • *
  • Posts: 2
  • Karma: +0/-0
Sony STR-242S issue when equaliser attached
« on: January 18, 2022, 06:54:42 PM »
As the title says, I have a Sony STR-242S that runs flawlessly until I attach any equaliser (have tried 3 different devices from 3 manufacturers, one Technic, one Genexxa, and an Akai).  Once I attach the equaliser, all sound becomes ridiculously quiet, normally I would have the volume at '2' (there's no numbers on mine, so I'm guessing), but need to crank it up to 10-15 just to hear it.  Also the sound is very scratchy, almost like it's clipping.  It's the same results whether I use output 1 or 2 and no matter the input.  The equalisers work fine on other amplifiers, so I'm hoping someone knows where I should start looking inside the Sony, maybe a worn out component, maybe it just can't put out enough power for an equaliser but the sound through the speakers I have is pretty good (it will make things fall off the walls if I turn it up enough).

Offline Sir Thrift-a-Lot

  • Ready For Intervention!
  • ******
  • Posts: 4132
  • Karma: +1/-0
Re: Sony STR-242S issue when equaliser attached
« Reply #1 on: January 19, 2022, 12:05:12 AM »
Are you placing it in the tape loop?   Try hitting the tape monitor switch with a few blasts of DeOxit.

Offline arendedwinter

  • FNG !!!
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Sony STR-242S issue when equaliser attached
« Reply #2 on: January 19, 2022, 02:08:07 AM »
If by tape loop you mean the tape input, then this is the main one I use but the player input acts the same (although much louder and over the top bass, don't know what that's about. Also noticed when using the tape input, if I switch to player with no device attached to the input I can hear the tape input if I turn the volume up enough as well as a lot of rhythmic noise). Gave everything a good blast with deoxit twice just to be sure, no change.

Offline MacGeek

  • Ready For Intervention!
  • ******
  • Posts: 1593
  • Karma: +1/-0
Re: Sony STR-242S issue when equaliser attached
« Reply #3 on: January 19, 2022, 08:51:28 AM »
I took a look at an on-line photo of the Sony.  It appears there is no tape monitor function, or pre-amp/power-amp in/out capability.    As such, if you are connecting the EQ unit to the tape in/out jacks, there is no signal to monitor-the receiver is "playing" the equalizer.

I don't think this receiver allows for the use of an outboard EQ
Mac stuff, Sony HDR-F1HD AM/FM/HD tuner, Denon DRS 810 cassette, Denon CDR-W1500 CD recorder, Music Hall MMF-9 w/B&O MMC2, B & O 4002 w/B & O 20 CL, Revox A-77